Обзор
Top Next

ICE Book Reader Professional - это мощная читалка электронных текстов (книг)

ICE Book Reader Professional сделан для того, чтобы сделать чтение текстовых файлов (электронных книг) удобным и комфортным. Почему это важно ? Чтение HTML страниц, документации или почты сильно отличается от чтения электронных книг. Чтение книг требует гораздо больше времени. Поэтому нагрузка на глаза гораздо сильнее. Кроме того, чтение книг это процесс обычно непрерывный. В то время как во время чтения HTML страниц, чтение постоянно чередуется с коротким отдыхом.

Это означает, что для чтения книг следует создавать более коморфтные условия. В противном случае глаза будут быстро уставать и появляется серьезный риск ухудшить свое зрение. Основная задача ICE Book Reader Professional - это сделать все возможное для предотвращение ухудшения зрения во время длительного чтения.

Береги зрение, пока это возможно !

ICE Book Reader Professional может предложить новые технологии, которые могут спасти Ваши глаза:
Ультра плавный скроллинга текста. Точный контроль скорости скроллинга
Автоматически настраиваемая скорость скроллинга
Сглаживание текста (full text antialising)
Супер скроллинг с субпиксельной точностью
Волновой скроллинг (скроллинг без движущегося текста)
Раскрашивание первых букв в начале каждого параграфа и заголовков
Искусственный интеллект примененный для распознования формата текста
Автоматическое переформатирование и режим оригинальной разметки

Кроме того ICE Book Reader Professional предлагает новой способ чтения книг: ктение книг с большого расстояни от монитора, как если Вы смотрите телевизор. Просто попробуйте этот метод у Вы увидите, что очень удобно:

point Нет необходимости вплотную сидеть перед экраном монитора. Вы можете лечь на диван или сесть в кресле на расстоянии 2-3 метров от монитора. Ваш позвоничник не будет уставать от длительного сидения на стуле.

point Чтение текста с большего расстояния, чем обычное расстояние от монитора, позволит предотвратить развитие близорукости.

point Вам не нужно напрягать зрение, чтобы разгладывать мелкие буквы с большого расстояния. ICE Book Reader Professional позволяет устанавливать любой размер букв.

point Чтение книг с большого расстояния означает, что Вы не сможете бегать к компьютеру каждый раз чтобы перелистнуть страницу. Если Вы используете ICE Book Reader Professional, то Вам не нужно никуда бегать. ICE Book Reader Professional автоматически настраивает скорость, в зависимости от плотности текста на странице.

point Многие люди не любят читать текст во время скроллинга. Также, некоторые старые ЖК мониторы не могут скроллировать текст без "хвостов". Это не проблема для ICE Book Reader Professional, так как в ICE Book Reader Professional имеется режим автоматического листания. При этом пауза между листаниями может быть как фиксированной, так и переменной. В зависимости от плотности текста на странице. Также существует другое решение - это волновой скроллинг. Волновой скроллинг (скроллинг без движущегося текста).


Что может ICE Book Reader professional
Previous Top Next

ICE Book Reader Professional может всё, что нужно для комфортного чтения:

В ICE Book Reader Professional имеется три режима просмотра: плавный скроллинг, режим автоматического листания и режим ручного листания.

ICE Book Reader может читать тексты из TXT, HTML, RTF, документы Microsoft Word и книги PALM (.PDB и .PRC).

ICE Book Reader может читать файлы напрямую из архивов: ZIP, RAR, ARJ, LZH и HA. Внешние архиваторы не требуются.

Оптимизированное ядро ICE Book Reader professional позволяет просматривать текстовые файлы размером до 1 гигабайта без видимых задержек.

Специальный режим поиска обеспечивает чрезвычайно быстрое перемещение по тексту, скорость перелистывания до 30 страниц в секунду.

ICE Book Reader позволяет изменять размер кэша. В пределах кэша перемещение по тексту происходит чрезвычайно быстро, независимо от выбранного режима работы.

ICE Book Reader автоматически раскрашивает любой текст. Первые буквы каждого параграфа и также все заголовки автоматически раскрашиваются в выбранные цвета. Это помогает видеть глазам дополнительные опорные точки во время чтения.

Ультра плавный скроллинг текста со скоростью от 1 до 500 линий в секунду. Прецизионный контроль скорости скроллинга необходим для комфортного чтения. Скроллинг текста реализованный в других приложениях используя третью кнопку мыши не позволяет точно контроль скорость скроллинга.

Имеется два режима скроллинга: постоянная скорость скроллинга и переменная скорость скроллинга. При выборе переменной скорости скроллинга, скорость скроллинга будет менять автоматически в зависимости от плотности текста. Чем больше слов/букв, тем медленнее скроллинг.

ICE Book Reader автоматически определяет Вашу скорость чтения и определяет требуемые скорости скроллинга или листания. Для этого необходимо прочитать в ручном режим две страницы.

Система искусственного интеллекта позволяет корректно распознавать формат любых текстовых файлов (параграфы, отступы, пробелы) без ошибок.

Полноэкранное сглаживание с различными масками (2x2, 3x3 и 4x4) может сделать чтение более комфортным. Новое мультипотоковое ядро позволяет создавать сглаженный текст без видимых задержек.

Супер плавный скроллинг позволяет генерировать дополнительные шаги с субпиксельной точностью. Вместо одного шага, во время работы супер плавного скроллинга делается 2, 3 или 4 шага. Эта технология похожа на технологию удвоения частоты используемую в телевизорах с разверткой 100 Гц.

Некоторые тонкие и мелкие шрифты могут создавать эффект мерцания текста. Для предотвращения этого, ICE Book Reader professional имеет специальный фильтр подавляющий это мерцание.

ICE Book Reader имеет полноценную поддержку Unicode. Это означает, что ICE Book Reader поддерживает любые языки и кодировки текста, из доступных в MS Windows. *

ICE Book Reader корректно показывает файлы на любом языке, независимо от версии Windows. Необходимо только иметь соответствующие шрифты.

Существует два различных режима: автоматическое переформатирование и оригинальное форматирование. Первый режим позволяет читать текст используя любой размер шрифта. Во втором режиме текст показывается без изменения формата.

ICE Book Reader гарантирует, что любой текст будет показан без необходимости использования горизонтального скроллинга.

Все свойства шрифтов можно изменять по желанию: размер, цвет, атрибуты (bold, italic, ...), кернинг (межбуквенный интервал), межстрочный интервал, интервал между параграфами. Более того, теперь для всех интервалов допустимы отрицательные величины. То есть, можно отображать текст с перехлёстом букв без видимых искажений.

Теперь возможно использование в качестве моноширных шрифтов любые шрифты.

ICE Book Reader помнит положение в файле для каждого файла. Также для каждого можно сделать неограниченно число закладок.

ICE Book Reader хранит все импортированные тексты в собственной библиотеке. Это позволяет быстро просматривать содержимое файлов без открытия самих документов.

ICE Book Reader имеет систему, определяющую автора книги и её название. Несколько книг одного автора автоматически объединяются в единую группу в библиотеке.

ICE Book Reader блокирует screensaver, убирает мышиный курсор и повышает свой приоритет до уровня HIGH во время скроллинга.

ICE Book Reader может легко менять язык интерфейса

ICE Book Reader имеет гибкую систему профилей. Вы можете выбрать любое сочетание опций, которые могут быть сохранены как профиль. Позже Вы можете активировать этот профиль и восстановить все выбранные опции. Система профилей позволяет как, сохранять опции для разных пользователей ICE Book Reader, так и устанавливать выбранные опции отдельно (смена цвета, размера шрифта, ...).

Вместе с ICE Book Reader возможно использовать любую беспроводную мышь как пульт дистанционного управления. Для этого необходимо поместить мышиный курсор над часами на тулбаре и использовать мышиные кнопки и колёсико для навигации по тексту.

* Русская версия ICE Book Reader позволяет просматривать текст только в следующих кодировках (866, 1251, KOI8, ISO, MAC)


Аппаратные требования

ICE Book Reader professional можно использовать в двух режимах: с включенным автоскроллингом и без него. Соответственно аппаратные требования будут различны:

Without using auto scrolling
Windows 9x, 2000, XP
Pentium или лучше
CPU с частотой 60 MHz или выше
64 MB RAM (для ICE Book Reader professional)
Видеокарта поддерживающая 32768 цветов или больше

Включенный автоскроллинг
Windows 9x, 2000, XP
Pentium-II или лучше
CPU с частотой 500 MHz или выше
64 MB RAM (для ICE Book Reader professional)
Видеокарта поддерживающая 32768 цветов или больше

Включенный Супер плавный скроллинг
Windows 9x, 2000, XP
Pentium-III или лучше
CPU с частотой 1 ГГц или выше
128 MB RAM (для ICE Book Reader professional)
Видеокарта поддерживающая 32768 цветов или больше
Видеокарта имеющая минимум 32 MB. Рекомендуется 64 MB
Видеокарта класса GeForce 3 или лучше

Для открытия документов Microsoft Word необходимо иметь на компьютере Microsoft Word версии не ниже MS Word 97 - (Word 97, Word 2000, Word XP или более поздний).

ICE Book Reader professional использует для перекодировки кодировки имеюшие в Windows. Обычно все необходимые кодировки имеются в системе. В случае их отсутствия, необходимо их инсталлировать.

ICE Book Reader требует мощный процессор. Особенно в случае включенного сглаживания. Закройте все другие приложения, если вы хотите иметь плавный скроллинг.


Ультра плавный скроллинг

Скроллинг - это очень простая операция. Необходимо с постоянной частотой сдвигать изображение. Теоретически это решается очень просто: необходимо использовать таймер для задания временных интервалов. Например: для скроллинга со скоростью 150 линий в секунду необходимо выполнять сдвиг каждые 1000/150 = 7 миллисекунд. К сожалению, в Microsoft Windows внутренние часы работают с частотой 100 Гц или ниже. Эта частота зависит от версии операционной системы и процессора. Это означает, что минимальная задержка, которая может быть сделана в MS Windows равна 10 миллисекундам. Таким образом, используя стандартные средства операционной системы возможно осуществлять скроллинг только со следующими частотами: 100 Гц, 50 Гц, 33 Гц, 25 Гц, 20 Гц, и т.д.

ICE Book Reader использует собственную технологию контроля частоты скроллинга. Это позволяет задавать частоту скроллинга с высокой точностью в широком диапазоне частот: 1 Гц - 500 Гц с точность 1 Гц.


Переменная скорость скроллинга

Этот режим может сделать чтения комфортным. В этом режиме ICE Book Reader professional динамически изменяет скорость скроллинга в соответствии с количеством текста на экране. Чем больше текста, тем медленнее скроллинг. Достаточно установить оптимальную скорость скроллинга один раз. В дальнейшем, ICE Book Reader professional будет контролировать скорость скроллинга автоматически.


Сглаживания текста (full text antialising)

Сглаживания текста (full text antialising) - это технология, когда вместо выбранного шрифта используется шрифт, который больше 2, 3 или 4 раза. Но перед выводом на экран, изображениe содержащее текст уменьшается в 2, 3 или 4 раза соответственно. Сглаживания текста (full text antialising) делает текст лучше читаемым:

Буквы сглаженного текста более ровные, без зазубрин и размытия

Оригинальный текст без сглаживания
01a

Сглаженный текст
01b

Сглаживание текста применяется не к отдельным буквам, а ко всему тексту в целом. В результате, каждая буква размещается с субпиксельной точностью

02

Чем больше размер шрифта, тем качественнее передается оригинальная форма буквы. Даже после последующего уменьшения

Оригинальный текст, размер шрифта 20
03a

Оригинальный текст, размер шрифта 80
03b

Оригинальный текст увеличенный в 4 раза (для сравнения), размер шрифта 20
03c

Если уменьшить оба фрагмента текста (размера 80 и увеличенного фрагмента размера 20), можно увидеть:
01b
01a

Особенно хорошо дополнительные детали заметны на примере верхней части буквы 'E'. Хорошо видно, что сглаживания текста (full text antialising) воспроизводит текст гораздо качественней

Существует другое решение улучшения разрешающей способности шрифта, используемое в Microsoft Reader - ClearType. ClearType использует другой путь для улучшения читаемости текста. К сожалению, было обнаружено, что ClearType воспроизводит текст более размытым. Кроме того текст передается со значительными цветовыми искажениями. Поэтому ClearType менее комфортен для чтения, чем full text antialising.


Почему сглаживание текста (text antialising) не применяется в других программах ?

Сглаживание текста применяется в некоторых программах. Но эти программы не поддерживают плавный скроллинг. Очень трудно создавать сглаженный текст быстро. Для создания сглаженного текста с маской 4x4 для экрана 1024x768 необходимо создать изображение размером 4096x3072. Размер такой картинки составит около 37 мегабайт. После этого нужно уменьшить изображение в 4 раза. Основная проблема в том, что все эти операции нужно выполнять очень быстро: менее чем за 0.01 секунды (скорость 100 линий в секунду) или менее чем за 0.005 секунды (скорость 200 линий в секунду). Пока такой скорости генерации сглаженного текста удалось добиться только в ICE Reader Professional.


Что означают цифры, показываемые в правом верхнем углу экрана

Во время включенного скроллинга в правом верхнем углу ICE Reader professional можно увидеть цифры похожие на эти: fpsgood или fpsbad. Первая картинка показывает скорость скроллинга (линий в секунду). Вторая показывает скорость скроллинга (линий в секунду) и количество кадров, во время показа которых была потеряна синхронизация.

Первая картинка показывает, что скроллинг работает отлично. Нет выпадений. Вторая показывает, что во время показа двух кадров был потеряна синхронизация .


Почему появляются кадры с потерянной синхронизацией

Существует множество причин, почему это может случаться:

Компьютер был занят другой задачей в это время. Не стоит создавать архив параллельно с чтением книги.

Возможно Ваш компьютер недостаточно быстр, для плавного скроллинга с заданной скоростью. Не пытайтесь на Pentium-133 добиться скроллинга в 250 кадров в секунду.

Сглаживание текста (text antialising) требует мощного процессора. Для сравнения, компьютер оснащенный AthlonXP 2000 успевает производить скроллинг со включенным сглаживанием (4x4) без потери синхронизации со скоростью в 300 линий в секунду.

Супер скроллинг требует видеокарту с не менее чем 64 МБ DDRAM RAM. Например, GeForce 2 MX 32 MB SDRAM может обеспечить супер скроллинг без потери синхронизации при скоросоти не более 10-12 линий в секунду. Если Ваша видеокарта хуже, чем GeForce 2 64 МБ DDRAM - забудьте про супер скроллинг.


Скроллинг: аппаратный или программный

Программный скроллинг реализован в соответствии с тем, как фирма Microsoft рекомендует писать программы. А именно, каждый раз перерисовывается весь экран. Аппаратный скроллинг использует недокументированные возможности и работает напрямую с экранным буфером. А это означает, что этот режим теоретически менее стабилен. Рекомендуется всегда использовать аппаратный скроллинг, потому что он работает гораздо быстрее. Программный скроллинг стоит использовать только в случае, если аппаратный скроллинг функционирует неверно. Скроллинг в режиме DirectX использует Microsoft Direct X. Только в DirectX режиме может работать супер скроллинг. Однако, DirectX режим требует более мощные процессор и видео карту.


Перемещение: плавно/прыжок

Плавное перемещение означает, что после нажатия на клавиши (стрелки вверх или вних, PgUP или PgDown) ICE Book Reader professional будет сдвигать текст плавно. В режиме прыжка, происходит мгновенно перемещение, без скроллинга. Рекомендуется использовать плавное перемещение по умолчанию. Так как человеческий глаз в этом режиме имеет опорные точки для отслеживания перемещения текста. Режим прыжка оптимален на дисплеях с малой частотой регенерации изображения (ЖК-дисплеи). Также режим прыжка хорош для чтения без автоматического скроллинга.


Быстрое перемещение

Быстрое перемещние необходимо, если нужно быстро найти требуемый участок текста.


Контакты
Previous Top

Home page
http://www.ice-graphics.com

ICE Book Reader home page
http://www.ice-graphics.com/ICEReader

EMail support
support@ice-graphics.com


Библиотека

ICE Book Reader имеет не зависящую от языка и формата книги систему распознающую автора книги и её название. Группа книг одного автора автоматически объединяется в единую группу в библиотеке. Эта система определяет автора и название книги корректно в большинстве случаев. Однако, существуют некоторые ситуации, когда невозможно корректно определить автора и название книги. Например, эта система не сможет работать, если имеется только одна книга каждого автора. Поэтому, если Вы увидели, что ICE Book Reader не смог корректно определить авторов некоторых книг, это не ошибка.


Волновой скроллинг

Волновой скроллинг - это скроллинг без движущегося текста. Вместо плавного скроллинга текста происходит обновление текста волной. Этот режим чрезвычайно полезен для медленных LCD дисплеев. Кроме того, всем кому не нравится движущийся текст, могут использовать волновой скроллинг вместо ручного перемещения по тексту. Для волнового скроллинга не рекомендуется использовать "DirectX". Лучший режим для волнового скроллинга - это "Аппаратный".


Подавление дрожания

Некоторые тонки и мелкие шрифты могут вызывать появление дрожания текста во время супер скроллинга. Для предотвращения этого в ICE Book Reader имеется специальный фильтр. Не активизируйте этот фильтр без необходимости, так как включение этого фильтра может сделать текст более размытым.


Почему супер плавный скроллинг не применяется в других программах ?

Сделать супер плавный скроллинг не просто. Классический скроллинг не перерисовывает изображение на экране при каждом шаге скроллинга. Изображение сдвигается на 1 или несколько пикселов. А парерисоывается лишь малая его часть. Для супер плавного скроллинга необходимо перерисовывать всё изображение на каждом шаге. Более того, так как супер плавный скроллинг увеличивает скорость скроллинга в 2, 3 или 4 раза, реальный объем посылаемых данных на видеокарту достигает фантастических цифр. Например: при скроллинге 100 линий в секунду необходимо посылать на видео карту каждую секунду: 1024x768x4x100x4=1.2 гигабайта !!! Это превосходит пропускную способность AGP 2x в 2.5 раза. Никому еще не удавалось прокачивать такой объем данных в секунду. Кроме ICE Book Reader :)


Приоритет: качество/скорость

Режим поиска - это специальный режим для сверх быстрого перемещения по тексту. В этом режиме скорость листания может достигать до 30 страниц в секунду.


Профили

Профили позволяет сохранить любую группу настроек ICE Book Reader. Профиль может содержать в себе как одну опцию, так и любую комбинацию опций. Чтобе сделать профиль необходимо установаить настройки ICE Reader которые Вы хотите сохранить в профиле, нажать кнопку "Создать профиль", устаноавить какие опции необходимо сохранить в этом профиле и имя профиля, нажать OK. Для активизации профиля нужно просто выбрать этот профиль по имени.

Существует две задачи для решения которых профили необходимы:
Если двое или большее число пользователй использует одну и туже копию ICE Book Reader для чтения. Каждый пользователь может сохранить все настройки ICE Book Reader.
Для изменения настроек для различных режимов чтения. Например: чтение вблизи и издалека.


Размер кэша

ICE Book Reader использует внутренний кэш для хранения изображения текста. Без этого кэша трудно сделать быстрым перемещение по тексту. Большая величина кэша гарантирует, что можно перелистнуть множество страниц без видимых задержек. Однако, большой размер кэша требует много оперативной памяти (RAM). Если Ваш компьютер не имеет достаточно свободной RAM, не следует задавать слишком большой размер кэша. Также не рекомендуется использовать более 50% от всем доступной RAM. Кроме того, очень большой размер кэша может замедлить работу ICE Book Reader в некоторых других режимах.


Список активных клавиш

F1 Показывает HELP
Ins Включитть/выключить автоматический скроллинг
+ Увеличить скорость скроллинга
- Уменьшить скорость скроллинга
\ Полноэкранный режим
Num * Открыть / закрыть панель опций
Esc Завершить ICE Book Reader Professional

Space, PgDn Следующая страница
PgUp Предыдущая страница

Над текстом
Left Mouse Button Быстрое точное перемещение по тексту
Left Mouse Button + Shift Быстрое точное перемещение по тексту без скроллинга
Left Mouse Button + Ctrl Быстрое грубое перемещение по тексту
Middle Mouse Button Включитть/выключить автоматический скроллинг
Right Mouse Button Выпадающее меню
Mouse wheel Сдвинуть текст вперёд / Сдвинуть текст назад

Над часами в тулбаре
Left Mouse Button Следующая страница
Middle Mouse Button Включитть/выключить автоматический скроллинг
Right Mouse Button Предыдущая страница
Mouse wheel Следующая страница / Предыдущая страница


Способ 1

Возможно мгновенно переместиться на позицию процент которой известен. Существует два способа сделать это: из секции закладок нажать кнопку на toolbar или просто кликнуть мышкой на проценты.


Способ 2

Если нажать левую кнопку мыши и/или (Shift или Ctrl одновременно) над текстом и двигать её вверх-вниз, то будет происходить быстрое перемещение по тексту.


Способ 3

Активируйте Приоритет - "Режим поиска". В этом режиме перемещение по тексту будет происходить очень быстро.


Супер плавный скроллинг

Супер плавный скроллинг позволяет генерировать дополнительные шаги с субпиксельной точностью. Вместо одного шага, во время работы супер плавного скроллинга делается 2, 3 или 4 шага. Эта технология похожа на технологию удвоения частоты используемую в телевизорах с разверткой 100 Гц.

Анимированный пример супер плавного скроллинга: http://www.ice-graphics.com/ICEReader/FAQ.html